re = /\/?(\w+)(?=(?:\/\w+)+metastase\b)\/?/m
str = 'lever/botmetastase
kidney/lever/botmetastase
pancreas/kidney/lever/botmetastase
'
subst = '$1metastase '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result