$re = '@/?(\w+)(?=(?:/\w+)+metastase\b)/?@m';
$str = 'lever/botmetastase
kidney/lever/botmetastase
pancreas/kidney/lever/botmetastase
';
$subst = "$1metastase ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;