import Foundation
let pattern = #"/?(\w+)(?=(?:/\w+)+metastase\b)/?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
lever/botmetastase
kidney/lever/botmetastase
pancreas/kidney/lever/botmetastase
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1metastase "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)