import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/?(\\w+)(?=(?:/\\w+)+metastase\\b)/?";
final String string = "lever/botmetastase\n"
+ "kidney/lever/botmetastase\n"
+ "pancreas/kidney/lever/botmetastase\n";
final String subst = "$1metastase ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}