use strict;
my $str = 'lever/botmetastase
kidney/lever/botmetastase
pancreas/kidney/lever/botmetastase
';
my $regex = qr@/?(\w+)(?=(?:/\w+)+metastase\b)/?@mp;
my $subst = '$1metastase ';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";