using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_([0-9]{8})[_.]";
string input = @"/home/hadoop/20200221/dbo.DOSSIER_SEGMENT_COMPOSANT_TRANSPORT_20200222.csv.gz
fact_reserve_20190803_001.csv.gz";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}