// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"_([0-9]{8})[_.]").unwrap();
let string = "/home/hadoop/20200221/dbo.DOSSIER_SEGMENT_COMPOSANT_TRANSPORT_20200222.csv.gz
fact_reserve_20190803_001.csv.gz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}