import Foundation
let pattern = #"_([0-9]{8})[_.]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/home/hadoop/20200221/dbo.DOSSIER_SEGMENT_COMPOSANT_TRANSPORT_20200222.csv.gz
fact_reserve_20190803_001.csv.gz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)