use strict;
my $str = '/home/hadoop/20200221/dbo.DOSSIER_SEGMENT_COMPOSANT_TRANSPORT_20200222.csv.gz
fact_reserve_20190803_001.csv.gz';
my $regex = qr/_([0-9]{8})[_.]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}