package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_([0-9]{8})[_.]`)
var str = `/home/hadoop/20200221/dbo.DOSSIER_SEGMENT_COMPOSANT_TRANSPORT_20200222.csv.gz
fact_reserve_20190803_001.csv.gz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}