re = /_([0-9]{8})[_.]/
str = '/home/hadoop/20200221/dbo.DOSSIER_SEGMENT_COMPOSANT_TRANSPORT_20200222.csv.gz
fact_reserve_20190803_001.csv.gz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end