const regex = /_([0-9]{8})[_.]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_([0-9]{8})[_.]', 'g')
const str = `/home/hadoop/20200221/dbo.DOSSIER_SEGMENT_COMPOSANT_TRANSPORT_20200222.csv.gz
fact_reserve_20190803_001.csv.gz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}