$re = '/_([0-9]{8})[_.]/';
$str = '/home/hadoop/20200221/dbo.DOSSIER_SEGMENT_COMPOSANT_TRANSPORT_20200222.csv.gz
fact_reserve_20190803_001.csv.gz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);