#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<plugin>" & @CRLF & _
" <groupId>org\.eclipse\.tycho<\/groupId>" & @CRLF & _
" <artifactId>tycho-packaging-plugin<\/artifactId>" & @CRLF & _
" <version>\${tycho-version}<\/version>" & @CRLF & _
" <configuration>" & @CRLF & _
" <sourceReferences>" & @CRLF & _
" <generate>true<\/generate>" & @CRLF & _
" <\/sourceReferences>" & @CRLF & _
" <\/configuration>" & @CRLF & _
" <dependencies>" & @CRLF & _
" <dependency>" & @CRLF & _
" <groupId>org\.eclipse\.tycho\.extras<\/groupId>" & @CRLF & _
" <artifactId>tycho-sourceref-jgit<\/artifactId>" & @CRLF & _
" <version>\${tycho-extras-version}<\/version>" & @CRLF & _
" <\/dependency>" & @CRLF & _
" <\/dependencies>" & @CRLF & _
" <\/plugin>"
Local $sString = "<plugin>" & @CRLF & _
" <groupId>org.eclipse.tycho</groupId>" & @CRLF & _
" <artifactId>tycho-packaging-plugin</artifactId>" & @CRLF & _
" <version>${tycho-version}</version>" & @CRLF & _
" <configuration>" & @CRLF & _
" <sourceReferences>" & @CRLF & _
" <generate>true</generate>" & @CRLF & _
" </sourceReferences>" & @CRLF & _
" </configuration>" & @CRLF & _
" <dependencies>" & @CRLF & _
" <dependency>" & @CRLF & _
" <groupId>org.eclipse.tycho.extras</groupId>" & @CRLF & _
" <artifactId>tycho-sourceref-jgit</artifactId>" & @CRLF & _
" <version>${tycho-extras-version}</version>" & @CRLF & _
" </dependency>" & @CRLF & _
" </dependencies>" & @CRLF & _
" </plugin>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")