const regex = /<plugin>
<groupId>org\.eclipse\.tycho<\/groupId>
<artifactId>tycho-packaging-plugin<\/artifactId>
<version>\${tycho-version}<\/version>
<configuration>
<sourceReferences>
<generate>true<\/generate>
<\/sourceReferences>
<\/configuration>
<dependencies>
<dependency>
<groupId>org\.eclipse\.tycho\.extras<\/groupId>
<artifactId>tycho-sourceref-jgit<\/artifactId>
<version>\${tycho-extras-version}<\/version>
<\/dependency>
<\/dependencies>
<\/plugin>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<plugin>
<groupId>org\\.eclipse\\.tycho<\\\/groupId>
<artifactId>tycho-packaging-plugin<\\\/artifactId>
<version>\\${tycho-version}<\\\/version>
<configuration>
<sourceReferences>
<generate>true<\\\/generate>
<\\\/sourceReferences>
<\\\/configuration>
<dependencies>
<dependency>
<groupId>org\\.eclipse\\.tycho\\.extras<\\\/groupId>
<artifactId>tycho-sourceref-jgit<\\\/artifactId>
<version>\\${tycho-extras-version}<\\\/version>
<\\\/dependency>
<\\\/dependencies>
<\\\/plugin>', 'gm')
const str = `<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-packaging-plugin</artifactId>
<version>\${tycho-version}</version>
<configuration>
<sourceReferences>
<generate>true</generate>
</sourceReferences>
</configuration>
<dependencies>
<dependency>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-sourceref-jgit</artifactId>
<version>\${tycho-extras-version}</version>
</dependency>
</dependencies>
</plugin>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}