# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"<plugin>\n"
r" <groupId>org\.eclipse\.tycho<\/groupId>\n"
r" <artifactId>tycho-packaging-plugin<\/artifactId>\n"
r" <version>\${tycho-version}<\/version>\n"
r" <configuration>\n"
r" <sourceReferences>\n"
r" <generate>true<\/generate>\n"
r" <\/sourceReferences>\n"
r" <\/configuration>\n"
r" <dependencies>\n"
r" <dependency>\n"
r" <groupId>org\.eclipse\.tycho\.extras<\/groupId>\n"
r" <artifactId>tycho-sourceref-jgit<\/artifactId>\n"
r" <version>\${tycho-extras-version}<\/version>\n"
r" <\/dependency>\n"
r" <\/dependencies>\n"
r" <\/plugin>")
test_str = ("<plugin>\n"
" <groupId>org.eclipse.tycho</groupId>\n"
" <artifactId>tycho-packaging-plugin</artifactId>\n"
" <version>${tycho-version}</version>\n"
" <configuration>\n"
" <sourceReferences>\n"
" <generate>true</generate>\n"
" </sourceReferences>\n"
" </configuration>\n"
" <dependencies>\n"
" <dependency>\n"
" <groupId>org.eclipse.tycho.extras</groupId>\n"
" <artifactId>tycho-sourceref-jgit</artifactId>\n"
" <version>${tycho-extras-version}</version>\n"
" </dependency>\n"
" </dependencies>\n"
" </plugin>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.