// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<plugin>
<groupId>org\.eclipse\.tycho<\/groupId>
<artifactId>tycho-packaging-plugin<\/artifactId>
<version>\${tycho-version}<\/version>
<configuration>
<sourceReferences>
<generate>true<\/generate>
<\/sourceReferences>
<\/configuration>
<dependencies>
<dependency>
<groupId>org\.eclipse\.tycho\.extras<\/groupId>
<artifactId>tycho-sourceref-jgit<\/artifactId>
<version>\${tycho-extras-version}<\/version>
<\/dependency>
<\/dependencies>
<\/plugin>").unwrap();
let string = "<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-packaging-plugin</artifactId>
<version>${tycho-version}</version>
<configuration>
<sourceReferences>
<generate>true</generate>
</sourceReferences>
</configuration>
<dependencies>
<dependency>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-sourceref-jgit</artifactId>
<version>${tycho-extras-version}</version>
</dependency>
</dependencies>
</plugin>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}