re = /<plugin>
<groupId>org\.eclipse\.tycho<\/groupId>
<artifactId>tycho-packaging-plugin<\/artifactId>
<version>\${tycho-version}<\/version>
<configuration>
<sourceReferences>
<generate>true<\/generate>
<\/sourceReferences>
<\/configuration>
<dependencies>
<dependency>
<groupId>org\.eclipse\.tycho\.extras<\/groupId>
<artifactId>tycho-sourceref-jgit<\/artifactId>
<version>\${tycho-extras-version}<\/version>
<\/dependency>
<\/dependencies>
<\/plugin>/m
str = '<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-packaging-plugin</artifactId>
<version>${tycho-version}</version>
<configuration>
<sourceReferences>
<generate>true</generate>
</sourceReferences>
</configuration>
<dependencies>
<dependency>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-sourceref-jgit</artifactId>
<version>${tycho-extras-version}</version>
</dependency>
</dependencies>
</plugin>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end