import Foundation
let pattern = #"""
<plugin>
<groupId>org\.eclipse\.tycho<\/groupId>
<artifactId>tycho-packaging-plugin<\/artifactId>
<version>\${tycho-version}<\/version>
<configuration>
<sourceReferences>
<generate>true<\/generate>
<\/sourceReferences>
<\/configuration>
<dependencies>
<dependency>
<groupId>org\.eclipse\.tycho\.extras<\/groupId>
<artifactId>tycho-sourceref-jgit<\/artifactId>
<version>\${tycho-extras-version}<\/version>
<\/dependency>
<\/dependencies>
<\/plugin>
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-packaging-plugin</artifactId>
<version>${tycho-version}</version>
<configuration>
<sourceReferences>
<generate>true</generate>
</sourceReferences>
</configuration>
<dependencies>
<dependency>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-sourceref-jgit</artifactId>
<version>${tycho-extras-version}</version>
</dependency>
</dependencies>
</plugin>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)