import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<plugin>\n"
+ " <groupId>org\\.eclipse\\.tycho<\\/groupId>\n"
+ " <artifactId>tycho-packaging-plugin<\\/artifactId>\n"
+ " <version>\\$\\{tycho-version\\}<\\/version>\n"
+ " <configuration>\n"
+ " <sourceReferences>\n"
+ " <generate>true<\\/generate>\n"
+ " <\\/sourceReferences>\n"
+ " <\\/configuration>\n"
+ " <dependencies>\n"
+ " <dependency>\n"
+ " <groupId>org\\.eclipse\\.tycho\\.extras<\\/groupId>\n"
+ " <artifactId>tycho-sourceref-jgit<\\/artifactId>\n"
+ " <version>\\$\\{tycho-extras-version\\}<\\/version>\n"
+ " <\\/dependency>\n"
+ " <\\/dependencies>\n"
+ " <\\/plugin>";
final String string = "<plugin>\n"
+ " <groupId>org.eclipse.tycho</groupId>\n"
+ " <artifactId>tycho-packaging-plugin</artifactId>\n"
+ " <version>${tycho-version}</version>\n"
+ " <configuration>\n"
+ " <sourceReferences>\n"
+ " <generate>true</generate>\n"
+ " </sourceReferences>\n"
+ " </configuration>\n"
+ " <dependencies>\n"
+ " <dependency>\n"
+ " <groupId>org.eclipse.tycho.extras</groupId>\n"
+ " <artifactId>tycho-sourceref-jgit</artifactId>\n"
+ " <version>${tycho-extras-version}</version>\n"
+ " </dependency>\n"
+ " </dependencies>\n"
+ " </plugin>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}