use strict;
my $str = '<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-packaging-plugin</artifactId>
<version>${tycho-version}</version>
<configuration>
<sourceReferences>
<generate>true</generate>
</sourceReferences>
</configuration>
<dependencies>
<dependency>
<groupId>org.eclipse.tycho.extras</groupId>
<artifactId>tycho-sourceref-jgit</artifactId>
<version>${tycho-extras-version}</version>
</dependency>
</dependencies>
</plugin>';
my $regex = qr/<plugin>
<groupId>org\.eclipse\.tycho<\/groupId>
<artifactId>tycho-packaging-plugin<\/artifactId>
<version>\${tycho-version}<\/version>
<configuration>
<sourceReferences>
<generate>true<\/generate>
<\/sourceReferences>
<\/configuration>
<dependencies>
<dependency>
<groupId>org\.eclipse\.tycho\.extras<\/groupId>
<artifactId>tycho-sourceref-jgit<\/artifactId>
<version>\${tycho-extras-version}<\/version>
<\/dependency>
<\/dependencies>
<\/plugin>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}