#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^_]*(_[^_]*){3}[^_]*$"
Local $sString = "date_name1_name2_name3_extra" & @CRLF & _
"date_name1_name2_name3" & @CRLF & _
"date_name1_name2_name3_extra" & @CRLF & _
"date_name1_name2_name3_extra" & @CRLF & _
"date_name1_name2_name3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")