re = /^[^_]*(_[^_]*){3}[^_]*$/m
str = 'date_name1_name2_name3_extra
date_name1_name2_name3
date_name1_name2_name3_extra
date_name1_name2_name3_extra
date_name1_name2_name3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end