use strict;
my $str = 'date_name1_name2_name3_extra
date_name1_name2_name3
date_name1_name2_name3_extra
date_name1_name2_name3_extra
date_name1_name2_name3';
my $regex = qr/^[^_]*(_[^_]*){3}[^_]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}