package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^_]*(_[^_]*){3}[^_]*$`)
var str = `date_name1_name2_name3_extra
date_name1_name2_name3
date_name1_name2_name3_extra
date_name1_name2_name3_extra
date_name1_name2_name3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}