import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^_]*(_[^_]*){3}[^_]*$";
final String string = "date_name1_name2_name3_extra\n"
+ "date_name1_name2_name3\n"
+ "date_name1_name2_name3_extra\n"
+ "date_name1_name2_name3_extra\n"
+ "date_name1_name2_name3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}