// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^_]*(_[^_]*){3}[^_]*$").unwrap();
let string = "date_name1_name2_name3_extra
date_name1_name2_name3
date_name1_name2_name3_extra
date_name1_name2_name3_extra
date_name1_name2_name3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}