using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^_]*(_[^_]*){3}[^_]*$";
string input = @"date_name1_name2_name3_extra
date_name1_name2_name3
date_name1_name2_name3_extra
date_name1_name2_name3_extra
date_name1_name2_name3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}