$re = '/^[^_]*(_[^_]*){3}[^_]*$/m';
$str = 'date_name1_name2_name3_extra
date_name1_name2_name3
date_name1_name2_name3_extra
date_name1_name2_name3_extra
date_name1_name2_name3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);