#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(:?[^0-9'\-\., _!¡?÷?¿\\+=@#$%ˆ&*(){}|~<>;:[\]]+(:?['-]|, | |\.|\. |$))+$"
Local $sString = "Jacob Wellman" & @CRLF & _
"Wellman, Jacob" & @CRLF & _
"Wellman, Jacob Wayne" & @CRLF & _
"O'Shaughnessy, Jake L." & @CRLF & _
"John O'Shaughnessy-Smith" & @CRLF & _
"Kim" & @CRLF & _
"" & @CRLF & _
"TimmyTimmy" & @CRLF & _
"" & @CRLF & _
"Timmy O''Shaughnessy" & @CRLF & _
"John O'Shaughnessy--Smith" & @CRLF & _
"K3vin Malone" & @CRLF & _
"alert("Hello")" & @CRLF & _
"select * from users;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")