// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(:?[^0-9'\-\., _!¡?÷?¿\\+=@#$%ˆ&*(){}|~<>;:[\]]+(:?['-]|, | |\.|\. |$))+$").unwrap();
let string = "Jacob Wellman
Wellman, Jacob
Wellman, Jacob Wayne
O'Shaughnessy, Jake L.
John O'Shaughnessy-Smith
Kim
TimmyTimmy
Timmy O''Shaughnessy
John O'Shaughnessy--Smith
K3vin Malone
alert(\"Hello\")
select * from users;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}