re = /^(:?[^0-9'\-\., _!¡?÷?¿\\+=@#$%ˆ&*(){}|~<>;:[\]]+(:?['-]|, | |\.|\. |$))+$/m
str = 'Jacob Wellman
Wellman, Jacob
Wellman, Jacob Wayne
O\'Shaughnessy, Jake L.
John O\'Shaughnessy-Smith
Kim
TimmyTimmy
Timmy O\'\'Shaughnessy
John O\'Shaughnessy--Smith
K3vin Malone
alert("Hello")
select * from users;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end