use strict;
my $str = 'Jacob Wellman
Wellman, Jacob
Wellman, Jacob Wayne
O\'Shaughnessy, Jake L.
John O\'Shaughnessy-Smith
Kim
TimmyTimmy
Timmy O\'\'Shaughnessy
John O\'Shaughnessy--Smith
K3vin Malone
alert("Hello")
select * from users;';
my $regex = qr/^(:?[^0-9'\-\., _!¡?÷?¿\\+=@#$%ˆ&*(){}|~<>;:[\]]+(:?['-]|, | |\.|\. |$))+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}