using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(:?[^0-9'\-\., _!¡?÷?¿\\+=@#$%ˆ&*(){}|~<>;:[\]]+(:?['-]|, | |\.|\. |$))+$";
string input = @"Jacob Wellman
Wellman, Jacob
Wellman, Jacob Wayne
O'Shaughnessy, Jake L.
John O'Shaughnessy-Smith
Kim
TimmyTimmy
Timmy O''Shaughnessy
John O'Shaughnessy--Smith
K3vin Malone
alert(""Hello"")
select * from users;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}