package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(:?[^0-9'\-\., _!¡?÷?¿\\+=@#$%ˆ&*(){}|~<>;:[\]]+(:?['-]|, | |\.|\. |$))+$`)
var str = `Jacob Wellman
Wellman, Jacob
Wellman, Jacob Wayne
O'Shaughnessy, Jake L.
John O'Shaughnessy-Smith
Kim
TimmyTimmy
Timmy O''Shaughnessy
John O'Shaughnessy--Smith
K3vin Malone
alert("Hello")
select * from users;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}