import re
regex = re.compile(r"^(:?[^0-9'\-\., _!¡?÷?¿\\+=@#$%ˆ&*(){}|~<>;:[\]]+(:?['-]|, | |\.|\. |$))+$", flags=re.MULTILINE)
test_str = ("Jacob Wellman\n"
"Wellman, Jacob\n"
"Wellman, Jacob Wayne\n"
"O'Shaughnessy, Jake L.\n"
"John O'Shaughnessy-Smith\n"
"Kim\n\n"
"TimmyTimmy\n\n"
"Timmy O''Shaughnessy\n"
"John O'Shaughnessy--Smith\n"
"K3vin Malone\n"
"alert(\"Hello\")\n"
"select * from users;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")