#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^http:..|^https:..|\/.*"
Local $sString = "https://www.asd.google.com" & @CRLF & _
"https://www.google.net" & @CRLF & _
"https://www.google.co.nz" & @CRLF & _
"https://google.com" & @CRLF & _
"https://www.google.com/api?=login/someshit" & @CRLF & _
"https://www.google.com/ads/getmeadrink/api?0284230284782487871837871301-0/" & @CRLF & _
"www.google.com/ads/v1/api?139305u30u130130/quote/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")