use strict;
my $str = 'https://www.asd.google.com
https://www.google.net
https://www.google.co.nz
https://google.com
https://www.google.com/api?=login/someshit
https://www.google.com/ads/getmeadrink/api?0284230284782487871837871301-0/
www.google.com/ads/v1/api?139305u30u130130/quote/
';
my $regex = qr/^http:..|^https:..|\/.*/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}