import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http:..|^https:..|\\/.*";
final String string = "https://www.asd.google.com\n"
+ "https://www.google.net\n"
+ "https://www.google.co.nz\n"
+ "https://google.com\n"
+ "https://www.google.com/api?=login/someshit\n"
+ "https://www.google.com/ads/getmeadrink/api?0284230284782487871837871301-0/\n"
+ "www.google.com/ads/v1/api?139305u30u130130/quote/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}