re = /^http:..|^https:..|\/.*/im
str = 'https://www.asd.google.com
https://www.google.net
https://www.google.co.nz
https://google.com
https://www.google.com/api?=login/someshit
https://www.google.com/ads/getmeadrink/api?0284230284782487871837871301-0/
www.google.com/ads/v1/api?139305u30u130130/quote/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end