using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http:..|^https:..|\/.*";
string input = @"https://www.asd.google.com
https://www.google.net
https://www.google.co.nz
https://google.com
https://www.google.com/api?=login/someshit
https://www.google.com/ads/getmeadrink/api?0284230284782487871837871301-0/
www.google.com/ads/v1/api?139305u30u130130/quote/
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}