package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^http:..|^https:..|\/.*`)
var str = `https://www.asd.google.com
https://www.google.net
https://www.google.co.nz
https://google.com
https://www.google.com/api?=login/someshit
https://www.google.com/ads/getmeadrink/api?0284230284782487871837871301-0/
www.google.com/ads/v1/api?139305u30u130130/quote/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}