# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/>\s+</></g;t' <<< "<h4>Specifications</h4> <table> <tr> <td>Brand</td> <td>Dell</td> </tr> </table>"