import re
regex = re.compile(r">\s+<")
test_str = "<h4>Specifications</h4> <table> <tr> <td>Brand</td> <td>Dell</td> </tr> </table>"
subst = "><"
result = regex.sub(subst, test_str)
if result:
print(result)