use strict;
my $str = '<h4>Specifications</h4> <table> <tr> <td>Brand</td> <td>Dell</td> </tr> </table>';
my $regex = qr~>\s+<~p;
my $subst = '><';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";