#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)%([^%.]+)%|(?<!\$)\$(?:\{([^{}]+)\}|([^$.\s]+))"
Local $sString = "%ABC%" & @CRLF & _
"$ABC." & @CRLF & _
"$ABC$XYZ" & @CRLF & _
"" & @CRLF & _
"To add a bit more to this:" & @CRLF & _
"" & @CRLF & _
"${ABC}" & @CRLF & _
"" & @CRLF & _
" should yield ABC too. (ignore curly braces if present - non capture chars perhaps?)." & @CRLF & _
"if you have two successive dollar signs, such as "$$EFG", or "$${EFG}"," & @CRLF & _
"that should not appear in a regex result. (This is where either numbered or named back- references come into play - and the reason I contemplated them as non-capture groups). As I understand it, a group becomes a non-capture group with this syntax (?:)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")