import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "%([^%.]+)%|(?<!\\$)\\$(?:\\{([^\\{\\}]+)\\}|([^$.\\s]+))";
final String string = "%ABC%\n"
+ "$ABC.\n"
+ "$ABC$XYZ\n\n"
+ "To add a bit more to this:\n\n"
+ "${ABC}\n\n"
+ " should yield ABC too. (ignore curly braces if present - non capture chars perhaps?).\n"
+ "if you have two successive dollar signs, such as \"$$EFG\", or \"$${EFG}\",\n"
+ "that should not appear in a regex result. (This is where either numbered or named back- references come into play - and the reason I contemplated them as non-capture groups). As I understand it, a group becomes a non-capture group with this syntax (?:).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}