const regex = /%([^%.]+)%|(?<!\$)\$(?:\{([^{}]+)\}|([^$.\s]+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('%([^%.]+)%|(?<!\\$)\\$(?:\\{([^{}]+)\\}|([^$.\\s]+))', 'gm')
const str = `%ABC%
\$ABC.
\$ABC\$XYZ
To add a bit more to this:
\${ABC}
should yield ABC too. (ignore curly braces if present - non capture chars perhaps?).
if you have two successive dollar signs, such as "\$\$EFG", or "\$\${EFG}",
that should not appear in a regex result. (This is where either numbered or named back- references come into play - and the reason I contemplated them as non-capture groups). As I understand it, a group becomes a non-capture group with this syntax (?:).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}