using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%([^%.]+)%|(?<!\$)\$(?:\{([^{}]+)\}|([^$.\s]+))";
string input = @"%ABC%
$ABC.
$ABC$XYZ
To add a bit more to this:
${ABC}
should yield ABC too. (ignore curly braces if present - non capture chars perhaps?).
if you have two successive dollar signs, such as ""$$EFG"", or ""$${EFG}"",
that should not appear in a regex result. (This is where either numbered or named back- references come into play - and the reason I contemplated them as non-capture groups). As I understand it, a group becomes a non-capture group with this syntax (?:).";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}