import Foundation
let pattern = #"%([^%.]+)%|(?<!\$)\$(?:\{([^{}]+)\}|([^$.\s]+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
%ABC%
$ABC.
$ABC$XYZ
To add a bit more to this:
${ABC}
should yield ABC too. (ignore curly braces if present - non capture chars perhaps?).
if you have two successive dollar signs, such as "$$EFG", or "$${EFG}",
that should not appear in a regex result. (This is where either numbered or named back- references come into play - and the reason I contemplated them as non-capture groups). As I understand it, a group becomes a non-capture group with this syntax (?:).
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)